About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Com tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker
Ocorreu um erro neste dispositivo
2008-09-22

No Forum do EXCELer, foi apresentada a seguinte questão (adaptada):


“A tabela abaixo representa valores de taxas de juros aplicáveis nas datas indicadas, isto é, entre as datas indicadas aplicam-se as taxas que estão à frente.
      A                  B                  C
1 01/01/07    30/06/07       0,1058
2 01/07/07    31/12/07       0,1107
3 01/01/08    30/06/08       0,1120
4 01/07/08    31/12/08       0,1120


(Em que A= Data de Início
Em que B= Data de Fim
Em que C= Taxa a Aplicar)

Se um documento for emitido em 14/03/07 e contar juros até 11/05/08, é possível obter o valor dos juros na totalidade.


Eu pretendia obter no final valores parcelares, assim:


De 14/03/2007 a 30/06/2007 - 109 dias à taxa de 0,1058 = 31,60
De 01/07/2007 a 31/12/2007 - 184 dias à taxa de 0,1107 = 55,80
De 01/01/2008 a 11/05/2008 - 132 dias à taxa de 0,1120 = 40,50 “


Representemos então, o que se pretende:

 

image


Para calcularmos o número de dias entre as duas datas que contêm a mesma taxa de juro a aplicar, utilizaremos a seguinte fórmula:

Em E1: =(B1-A1)+1

Em E2: =(B2-A2)+1

Em E3: =(B3-A3)+1

(A formatação destas células deverá ser “Número”, sem casas decimais)


E agora, para calcularmos os valores dos juros, de forma parcelar, teremos:

Em F1: =ARRED(C1*E1/365*1000;2)

Em F2: =ARRED(C2*E2/365*1000;2)

Em F3: =ARRED(C3*E3/365*1000;2)

(A formatação destas células deverá ser “Número”, com 2 casas decimais)

 

Tópicos relacionados: