Search

A carregar...

About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker

Facebook Share

2014-03-16
Há dias, tive necessidade de configurar o procedimento Workbook_Open() com algumas particularidades.

Deixo aqui o exemplo:


'---------------------------------------------------------------------------------------
' Procedure : Workbook_Open
' Author    : JRod
' Date      : 16/03/2014
' Purpose   : Activa determinada folha, tira a barra com o nome das folhas e abre folha sempre com o zoom a 85%
'---------------------------------------------------------------------------------------
'
Private Sub Workbook_Open()

    'Activa a folha PROGRESSIVO
    Sheets("PROGRESSIVO").Activate
   
    'Tira a barra com os nomes das folhas...
    ActiveWindow.DisplayWorkbookTabs = False
   
    'Abre s folha (planilha)"PROGRESSIVO" sempre com o zoom a 85%
    ActiveWindow.Zoom = 85

End Sub
2014-03-11
Se pretendermos ver quantas vezes determinado nome é referido num range, que se encontra dependente de um outro, como no exemplo que a seguir se pode ver:
Atendedor
e partindo  do princípio que o range da coluna C não pode conter células em branco, uma vez que não fará sentido, pois é para colocar lá um nome, podemos utilizar a seguinte fórmula, como matriz, sendo que a procura é baseada na célula C2 e a resposta dada (que contém a fórmula abaixo), na célula
 E2:=SOMA(SE(C2=$B$5:$B$24;1/(CONTAR.SE.S($B$5:$B$24;C2;$C$5:$C$24;$C$5:$C$24));0))
 
Como matriz que é, a fórmula deverá ser inserida com CTRL + SHIFT + ENTER, para ficar assim:
 
{=SOMA(SE(C2=$B$5:$B$24;1/(CONTAR.SE.S($B$5:$B$24;C2;$C$5:$C$24;$C$5:$C$24));0))}
2011-10-01

MVP_Award_2011

 

URRA!!!! URRA!!!! URRA!!!!! Amigos!!!! Estou, mais uma vez, orgulhoso com o facto de ter voltado a ser, em 2011 e pela 7ª vez consecutiva, agraciado com o Microsoft MVP Award !!!!

 

Obrigado, Cristina Gonzalez, pela confiança!!!! Bem haja e felicidades!!!!! Vou continuar, com todo o entusiasmo, a promover o EXCELer!!!

 

Obrigado, Bruno Castro, por me aturar sempre que preciso de algo novo para o EXCELer!!!!!

 

Obrigado a todos os EXCELerianos!!!!!! MUITO OBRIGADO!!!!!!

2011-07-31

Para ver em formato PDF, aceder a:

Guia Rápido de referência - Excel 2010

 

Para saber como criar uma tabela em Excel, de maneira fácil. CLICAR AQUI

2011-07-19

Para saberem como fazer, vejam o texto escrito pelo Microsoft Excel MVP – Ron de Bruin:

 

Criar e enviar ficheiros em formato PDF

2011-04-18

Exemplo para filtrar e copiar para outra folha:

Supondo que temos a seguinte tabela:

O que se pretende, é copiar para outra folha (ex. folha2) os registos que contenham apenas a sigla pretendida:

O exemplo de código possível:

Sub FiltrarECopiar()

Dim Msg As String

Sheets("Folha2").Select

Columns("A:C").Select

Selection.ClearContents

Sheets("Folha1").Select

Msg = InputBox(" Escreva as siglas para filtrar")

Msg = UCase(Msg)

Range("C2").AutoFilter Field:=3, Criteria1:=Msg

Range("A2").Resize(Range("A" & Rows.Count).End(xlUp).Row - 1).EntireRow.Copy _

Destination:=Sheets("Folha2").Range("A1")

ActiveSheet.ShowAllData

End Sub

 

Créditos para o MVP J.E. McGimpsey

2010-10-29

Há dias, no Fórum do Exceler, colocaram a seguinte questão:

“Eu tenho uma tabela onde a Coluna A4:A19 contem datas, e as colunas B4:G19 tenho dados.E no B2"Data" critério.
Eu quero SUMIF onde as colunas B4:G19 sejam somadas quando o critério for verdade.
Eu fiz  =SUMIF(A4:A19,B2,B4:B19) mas esta somando somente a Coluna B ao invés de B4:G19
Por favor veja a foto em anexo.

 

A resposta possível poderá ser:

Uma das hipóteses, utilizando a função SUMIF (SOMA.SE),será a seguinte fórmula:

=SUMIF(A4:A19,B2,B4:B19)+SUMIF(A4:A19,B2,C4:C19)+SUMIF(A4:A19,B2,D4:D19)+SUMIF(A4:A19,B2,E4:E19)+SUMIF(A4:A19,B2,F4:F19)+SUMIF(A4:A19,B2,G4:G19)


A outra, melhor, na minha opinião, utilizando a função SUMPRODUCT ( SOMARPRODUTO), será:

=SUMPRODUCT((A4:A19=B2)*B4:G19)

Há mais opiniões? Serão, como sempre, muito bem vindas!

Tópicos relacionados:

2010-10-02

 

Recebi ontem a mensagem sobre a minha 6ª renomeação consecutiva como MVP Excel! Claro que estou satisfeitíssimo e vou tentar, como sempre, não desiludir a comunidade!!!

 


“Dear Jorge Rodrigues,
Congratulations! We are pleased to present you with the 2010 Microsoft® MVP Award! This award is given to exceptional technical community leaders who actively share their high quality, real world expertise with others. We appreciate your outstanding contributions in Excel technical communities during the past year.”

2010-07-27

Para saber sobre funcionalidades descontinuadas e modificadas no Excel 2010, aceda a:

Conversão de ficheiros e compatibilidades 01

 

Para saber como adicionar ou remover suplementos no Excel 2010, aceda a:

Analisar dados

 

Tópicos relacionados: