About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Com tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker
Ocorreu um erro neste dispositivo
2010-03-21

Mais uma vez, fui ao MVP Open Day!… Um espectáculo, como sempre!!!!!

E vi, pela primeira vez, o Power Pivot Add-In a funcionar:

image

Há dias, no fórum do Exceler, foi colocada a seguinte questão (adaptada):

“ Tenho a seguinte tabela:

image

Queria que na coluna V.Max. e Loja, a fórmula fizesse o seguinte:

  • Procurasse o valor máximo de um determinado nome (ex. João) e juntasse a loja a que correspondesse  esse valor máximo: ou seja, onde está João, escolheria das 3 linhas onde o nome se encontra, o valor máximo, neste caso, 13 e a Loja que lhe corresponde, ou seja, Loja2.”

Então, o que pretenderíamos, seria o seguinte:

image

Em G3, digitamos o nome pretendido (no exemplo, João);

Em D3, digitamos a seguinte fórmula de matriz (Array):

{=MÁXIMO(SE($A$3:$A$12=G3;$C$3:$C$12))}

 Nota: O Array é conseguido com as { }, que se obtém através da combinação das teclas CTRL + SHIFT + ENTER.

Para finalizar, em E3, digitamos a seguinte fórmula:

=SE(G3="";0;ÍNDICE($B$3:$C$12;CORRESP(D3;$C$3:$C$12;0);1))

 

O resultado está, então, à vista!…

 

Tópicos relacionados:

2010-03-01

Uma pequena (grande) curiosidade:

Desenhar a cara do rato Mickey, para ficar assim:

image

Querem saber como? Então, acedam a: Rato Mickey e divirtam-se!