Blog Archive

About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Com tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker
Ocorreu um erro neste dispositivo
2004-10-23
Às vezes, no EXCEL, quando se pretende efectuar uma divisão, o dividendo é menor que o divisor, ou a célula que funciona como dividendo, porque fazendo parte de uma fórmula, encontra-se vazio. Neste caso, aparecerá na célula do resultado aquela mensagem abominável que todos nós conhecemos:"#/DIV0!".

Bom, há, pelo menos, duas maneiras de resolver o problema:

1- Utilizando uma fórmula na célula do resultado:
Ex - assumindo que a célula do resultado é C1, que a célula do dividendo é A1 e que a célula do divisor é B1, teremos:

=IF(ISERR(A1/B1);"";A1/B1)

ou em português:

=SE(É.ERRO(A1/B1);"";A1/B1)

2- Utilizando o VBA:

Ex:
Assumindo que a coluna de resultados é a coluna C (no exemplo o range
será C1:C40, mas pode ser o que se quiser), teremos:

Private Sub Worksheet_SelectionChange(ByVal Target As Range)

Dim Newrange As Range

Set Newrange = Range("C1:C40")
For Each Cell In Newrange
If IsError(Cell.Value) Then
Cell.Value = ""
End If
Next Cell

End Sub