Search

A carregar...

About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Com tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker
Ocorreu um erro neste dispositivo
2014-03-16
Há dias, tive necessidade de configurar o procedimento Workbook_Open() com algumas particularidades.

Deixo aqui o exemplo:


'---------------------------------------------------------------------------------------
' Procedure : Workbook_Open
' Author    : JRod
' Date      : 16/03/2014
' Purpose   : Activa determinada folha, tira a barra com o nome das folhas e abre folha sempre com o zoom a 85%
'---------------------------------------------------------------------------------------
'
Private Sub Workbook_Open()

    'Activa a folha PROGRESSIVO
    Sheets("PROGRESSIVO").Activate
   
    'Tira a barra com os nomes das folhas...
    ActiveWindow.DisplayWorkbookTabs = False
   
    'Abre s folha (planilha)"PROGRESSIVO" sempre com o zoom a 85%
    ActiveWindow.Zoom = 85

End Sub
2014-03-11
Se pretendermos ver quantas vezes determinado nome é referido num range, que se encontra dependente de um outro, como no exemplo que a seguir se pode ver:
Atendedor
e partindo  do princípio que o range da coluna C não pode conter células em branco, uma vez que não fará sentido, pois é para colocar lá um nome, podemos utilizar a seguinte fórmula, como matriz, sendo que a procura é baseada na célula C2 e a resposta dada (que contém a fórmula abaixo), na célula
 E2:=SOMA(SE(C2=$B$5:$B$24;1/(CONTAR.SE.S($B$5:$B$24;C2;$C$5:$C$24;$C$5:$C$24));0))
 
Como matriz que é, a fórmula deverá ser inserida com CTRL + SHIFT + ENTER, para ficar assim:
 
{=SOMA(SE(C2=$B$5:$B$24;1/(CONTAR.SE.S($B$5:$B$24;C2;$C$5:$C$24;$C$5:$C$24));0))}