Search

A carregar...

About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Com tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker
Ocorreu um erro neste dispositivo
2010-07-27

Para saber sobre funcionalidades descontinuadas e modificadas no Excel 2010, aceda a:

Conversão de ficheiros e compatibilidades 01

 

Para saber como adicionar ou remover suplementos no Excel 2010, aceda a:

Analisar dados

 

Tópicos relacionados:

O site de David McRitchie é um local de consulta obrigatória, porque tem exemplos muito bons.

Ora vejam:

My Excel Pages -- David McRitchie

Tomemos, por exemplo, o seguinte:

image

O que se pretende, é criar uma fórmula que altere o texto de A1, para que as células B1 (com formatação de data personalizada, na forma aaaa-mm-dd) e B8 (sem formatação de data personalizada) se apresentem como na imagem.

Aqui fica, a título de exemplo, uma possível solução:

image Em português: =DATA(DIREITA(A1;4);EXT.TEXTO(A1;3;2);ESQUERDA(A1;2))

2010-07-17

A propósito deste título, apresento 2 possíveis soluções para esta situação: Como saber quantas vezes o conteúdo de uma célula se encontra num determinado Range de células?

Vejamos o exemplo:

image

O que se pretende, é saber quantas vezes o número 3 (referenciado na célula A1) está contido no Range B1:B10. Ora, como se pode verificar, está contido por 3 (três) vezes.

Então,

1ª solução – Função CONTAR.SE() – versão 2003/2007 ou Função CONT.SE() – versão 2010:

=CONTAR.SE(B1:B10;A1)

=CONT.SE(B1:B10;A1)

 

2ª solução – Função SOMA(), como um Array {} (obtido com as teclas Ctrl + Shift + Enter):

{=SOMA((A1=B1:B10)*1)}

 

Tópicos relacionados: