Search

A carregar...

About Me

A minha fotografia
JRod - PORTUGAL
Microsoft [MVP] - Excel (10º ano consecutivo)
Ver o meu perfil completo
Com tecnologia do Blogger.

Seguidores

Estatisticas

Free Blog Counter

eXTReMe Tracker
Ocorreu um erro neste dispositivo
2010-02-16

Há dias, num grupo de discussão, foi apresentada a seguinte questão (adaptada):

Será que é possível arranjar um aviso de cada vez que se colocar informação duplicada numa coluna.


Ex : Numa folha de Excel com uma tabela onde apliquei filtros nas colunas.
         A                 B
1     12456           José
2     12354          Maria
3     12456         Manuel


Portanto, ao introduzir o nº em A3 aparecer um aviso de que aquele numero já estava escrito.

O que se pretende será, então o seguinte:

image

Para obter o resultado, podemos optar pela denominada “Validação de Dados” e criar uma fórmula que nos permita saber se o valor digitado já consta no Range estabelecido e, nesse caso, apresentar a mensagem de aviso.

Seguem-se os passos a dar:

  1. Marca-se o Range pretendido. No caso do exemplo, o Range será A1:A3, devendo iniciar-se a marcação sempre na célula de numeração mais baixa (ex: A1);
  2. De seguida, clica-se no menu “DADOS” e escolhe-se o item “Validação de Dados”.
  3. De seguida, escolhe-se o tabulador “Definições. É aqui que iremos escolher o critério de validação, no exemplo: “Personalizar” e inserirmos a fórmula:

    =CONTAR.SE($A$1:$A$3;A1)=1image 

  4. Depois, para termos o aviso de erro, escolhemos o tabulador com o mesmo nomeimage

Assim, se digitarmos o valor duplicado em A3, irá aparecer a mensagem acima apresentada.

De notar que, na mensagem há duas opções relevantes: Ou para continuar (SIM) ou para não continuar (NÃO).

Se clicar,os em SIM:

image

o resultado será o da aceitação do valor duplicado image

Se for NÃO, o resultado será a activação da célula em causa, para permitir a correcção image

Tópicos relacionados: